Talque

Technical Requirements

What technical requirements must my device meet?

System requirements for talque Web App

If possible, use the latest version of Google Chrome or Edge Chromium as your browser. Internet Explorer is not supported.

System requirements for the talque mobile app
  • iOS 12.5 or higher
  • Android 8 or higher

talque also requires access to several internet resources. If images or videos are not displayed, or if you cannot upload images, or if you cannot access talque video calls please contact your internal IT and pass on the following information about talque web resources requirements.